The PMACC password change client tool is changing the Oracle password but not the Peoplesoft passwor (NETIQKB30498)

  • 7730498
  • 02-Feb-2007
  • 08-Sep-2008

Resolution

fact
VigilEnt Security Agent for Oracle 1.x

fact
VigilEnt Password Manager for Oracle 6.x

symptom
The PMACC password change client tool is changing the Oracle password but not the Peoplesoft password.

cause
The PMACC tool requires registry entries to be made by the configuration utility tool provided. If the configuration is not done or is done incorrectly the end result will be a password change done for the Oracle account only and the Peoplesoft password will remain unchanged.

fix

A test to determine if the configuration has not completed or completed incorrectly is to select the login name and password from the PSOPRDEFN table before and after a PMACC tool password change. If the encrypted password does not change, something is not configured properly.

Common items to check: 

  • Does the SQLCQR user have the INSERT & UPDATE privileges on the SYSADM.PSOPRDEFN table? If not, grant these privileges to the SQLCQR user. The following SQL statement will show if the privilege has been granted: 

    select GRANTEE, OWNER, PRIVILEGE, TABLE_NAME from sys.dba_tab_privs where GRANTEE = 'SQLCQR'; 

  • Can the Datamover tool be started from the command line with the path provided during the configuration? If not, then map the proper network location to allow access. 
  • Is the SYSADM user able to log into the datamover executable? If not, check that the SYSADM Oracle account is not LOCKED or EXPIRED.
  • Does the Windows user running Datamover have the privilege to write to the "C:\temp" directory? 


Additional Information

Formerly known as NETIQKB30498