Error: 'Unable to determine Oracle version (from V$INSTANCE) - assuming V7.X.' (NETIQKB30025)

  • 7730025
  • 02-Feb-2007
  • 08-Sep-2008

Resolution

fact
VigilEnt Security Agent for Oracle 1.x

fact
VigilEnt Audit Manager for Oracle 3.x

fact
VigilEnt Audit Manager for Oracle 4.x

symptom
Error: 'Unable to determine Oracle version (from V$INSTANCE) - assuming V7.X.'

symptom
Error: 'ORA-00942: Table or view does not exist.'

cause
The Oracle error message 'ORA-00942 Table or view does not exist' is commonly caused by a missing Oracle privilege. VigilEnt Audit Manager for Oracle must be able to determine the Oracle version for 'SELECT' auditing. The auditing of 'SELECT' statements is only available in Oracle versions 8i and higher.

If the proper privileges have not been granted, the 'Unable to determine Oracle version (from V$INSTANCE) - assuming V7.X.' error is received when starting the console. After OK is clicked, another Oracle error pops up: 'ORA-00942: Table or view does not exist.'



fix
Using the SchemaInstall.exe, run the step with the following description:

Grant SELECT ANY TABLE to SQLCQR



Additional Information

Formerly known as NETIQKB30025

Feedback service temporarily unavailable. For content questions or problems, please contact Support.