Error: 'The DRA server encountered an error when loading the cache file for Security. The error code (NETIQKB29265)

  • 7729265
  • 02-Feb-2007
  • 19-Jun-2007

Resolution

fact
Directory and Resource Administrator 6.60

symptom
Error: 'The DRA server encountered an error when loading the cache file for Security. The error code is hr=800703f1=(The configuration registry database is corrupt)'.

symptom
Error found in the application log on the secondary DRA server.  

cause
The cause of this issue is due to resolution issues in the environment.

fix

To get the Secondary DRA server online, perform the following:

  1. Stop the MCS Onepoint Admin Service on the Secondary.
  2. Check the contents of the Refresh directory on the Secondary (C:\Program Files\NetIQ\DRA\Refresh).
       
  3. Delete the files in the Refresh Directory on the Secondary.  There may be multiple copies of each file but the files will start with the following:
    • AccountprimaryDRAserver2004xxxxxxxx
    • ExchangeprimaryDRAserver2004xxxxxxxx
    • PolicyprimaryDRAserver2004xxxxxxxx
    • SchemaprimaryDRAserver2004xxxxxxxx
    • SecurityprimaryDRAserver2004xxxxxxxx
    • ServerConfigurationprimaryDRAserver2004xxxxxxxx
  4. Copy the 6 files from C:\Program Files\NetIQ\DRA\Refresh\Old to C:\Program Files\NetIQ\DRA\Refresh\ on the Secondary.
  5. Restart the MCS Onepoint Admin Service on the Secondary.

The overall cause of the network issue must be addressed or this issue could occur again after the next scheduled MMS synchronization.

 



note

For Troubleshooting, try some basic network resolution steps like pinging the secondary from the primary, by machine name and running a Net View command from the Primary to the Secondary.  In addition, try manually copying one of the files in the primary C:\Program Files\NetIQ\DRA\Replication directory to the secondary.



Additional Information

Formerly known as NETIQKB29265