Error: 'Maximum number of KeyID columns reached or exceeded (10).' (NETIQKB28742)

  • 7728742
  • 02-Feb-2007
  • 08-Sep-2008

Resolution

fact
VigilEnt Security Agent for Oracle 1.x

fact
VigilEnt Audit Manager for Oracle 3.2x

fact
VigilEnt Audit Manager for Oracle 4.0x

symptom
Error: 'Maximum number of KeyID columns reached or exceeded (10).'

cause
User defined auditing does not allow more than 10 Key_id columns to be selected, even though the table/trigger and display all support 20 Key_ID columns.

fix
Please refer to the following steps to resolve the error:

WARNING: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved.  Make sure that you backup your Registry prior to making any changes.
  1. Shut down Audit Manager.
  2. Go to the registry and navigate to the following key:

    HKEY_LOCAL_MACHINE\Software\BrainTree Security Software\SQL<>SECURE\Audit Manager\V4
  3. Add the following registry value and data:
    DWORD value
    ValueName MaxKeyIDColumns
    Value Data (Hexidecimal) 20
  4. Start up Audit Manager.
    1. When Audit Manager starts up it will read in the new value and have the ability to create audit triggers with more than 10 key_id's.


    note
    The previous versions of Audit Manager did not include the ability to create audits with more than 10 key_id's. During the upgrade, this enhancement is normally added to the base install. However, there are a few rare cases where this does not complete.

    Additional Information

    Formerly known as NETIQKB28742