Error is received when running a VigilEnt Security Agent for Windows report from VigilEnt Security M (NETIQKB28339)

  • 7728339
  • 02-Feb-2007
  • 17-Apr-2008

Resolution

fact

VigilEnt Security Agent for Windows 2.x 



fact
VigilEnt Security Agent for Windows 3.x

fact
NetIQ Vulnerability Manager Agent for Windows 5.0

fact
VigilEnt Security Manager 4.x

fact
VigilEnt Security Manager 3.x

symptom
Error is received when running a VigilEnt Security Agent for Windows report from VigilEnt Security Manager.

symptom
Error: 'Target machine not in same domain'.

cause
The target machine in VigilEnt Security Manager may be a member of a workgroup, a resource domain, a standalone machine, or a machine in a domain with a different subnet.

fix

To determine if the machine is part of a workgroup or standalone machine, right-click My Computer (on the targeted machine) from the desktop and select Properties.  Selec the Network Identification tab.  Your Domain name or Workgroup name will be listed here. 

To resolve this error a value (DomainCheck) needs to be added to the registry on the agent machine as outlined below:

  1. Click Start | RunRegedit and browse to: HKEY_LOCAL_MACHINE\SOFTWARE\PENTASAFE\VSANT.
  2. Right-click HKEY_LOCAL_MACHINE\SOFTWARE\PENTASAFE\VSANT and select NEW and DWORD Value.
  3. Change the name of the DWORD to: DomainCheck . Leave the value set to 0.
  4. Exit Regedit, stop and restart the 'Windows/NT agent' service.

 



note

The agent will work on a workgroup machine for same-machine auditing, but will not be able to do proxy auditing of another machine. This is because proxy auditing only works for systems that are members of domains. 



Additional Information

Formerly known as NETIQKB28339