Proxy endpoints are not associated with the correct agents after upgrading. (NETIQKB27410)

  • 7727410
  • 02-Feb-2007
  • 08-Sep-2008

Resolution

fact
VigilEnt Security Manager 3.0 SR2

fact
VigilEnt Security Manager 4.0

symptom
Proxy endpoints are not associated with the correct agents after upgrading.

symptom
After upgrading to VSM 4.0, each endpoint incorrectly appears to have an agent installed on it when they should be monitored by an agent on another system.

cause

Proxy links were broken as a result of an issue after upgrading from VSM 3.0 SR2 to VSM 4.0 as described in these 2 situations:

  1. If the system that is hosting an agent, is NOT monitored by any agents, then each endpoint that the agent was monitoring by proxy is incorrectly migrated. The result is that each endpoint is setup as the system for an agent, thus all proxy links are broken.
  2. If the system hosting an agent was created after the endpoint to be monitored via proxy, then each endpoint that the agent was monitoring by proxy is incorrectly migrated. The result is that each endpoint is setup as the system for an agent, thus all proxy links are broken.


fix

Download NETIQKB27410.zip from the following link:

The following script contained in NETIQKB27410.zip  will re-populate the database tables used by the Asset Map to populate Agents and their relationships to systems and endpoints. No changes are made to systems or endpoints so the script can be run numerous times against any database that has just been upgraded from VSM 3.0 SR2 to VSM 4.0.  

Note: Please read the Notes listed in this article before running the script.

Unzip the NETIQKB27410.zip to a local drive on each platform that has a VigilEnt Database installed. Double-click NETIQKB27410.exe and follow the instructions for the database solution script.

After running the script, you will need to perform the following:

To auto register all agents:

  1. Navigate to Program Files\Pentasafe\VigilEnt Security Server.
  2. Double-click config.bat to execute it.  This will bring up the VigilEnt Security Server Configuration Utility with an Advanced Tab added.
  3. Select the Advanced Tab.
  4. Change the value of the 'VSS/upgrade/processed' field to False by deleting the word 'True' and typing 'False'.
  5. Click Apply to save your changes then close the Configuration Utility.
  6. Stop and Restart VigilEnt Security Server service.

For information on stopping and restarting services please refer to the following knowledge base article:

https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB25651



note

Backup database Before running this script. 



note
Any agent added after the migration and before this script is run, will be deleted during the execution of this script.

note
This script should only be used immediately after the upgrade has completed successfully.

note
On a clean install of 4.0, this script will exit without performing any tasks.

note
No users should be using VigilEnt Security Manager during this script execution!

note
After running the script, follow the instructions to auto register the agents.

Additional Information

Formerly known as NETIQKB27410