Resolution
Directory and Resource Administrator 6.60
symptom
HTTP 500 Timeout Error When Performing Operations in the Directory and Resource Administrator Web Console
symptom
Performing basic tasks in the Web Console may generate the following error in the display:
- The page cannot be displayed
symptom
Consistent slow performance in the Web Console.
symptom
The same functions perform normally in the MMC interface.
cause
The Web Console does not process Windows NT4 domain user accounts the same way the MMC does. The Web Console relies on the WinNT Provider to handle requests for user properties. Even though most user properties are contained in the Directory and Resource Administrator (DRA) cache, the nature of the WinNT Provider still requires a read from the SAM contained on the NT4 Primary Domain Controller (PDC). This is particularly true for the account disabled property. If the communication between the DRA server and the PDC of the managed Windows NT4 domain takes an excessive amount of time, the time to display a large number of users in the Web Console can become excessive. When this condition occurs, timeout errors can occur as well as other Assistant Admins experiencing extended wait times while the Administration server processes their requests.
fix
HotFix 27349 improves performance when managing Windows NT user accounts through the Web Console. If you frequently use the Web Console to manage user account properties, such as whether an account is disabled, apply this HotFix. If you attempt to access or modify a user account and the Web Console displays an error stating that the page cannot be displayed, apply this HotFix.
To install this HotFix, run the DRA66000_hotfix27349.exe file on each Administration server computer.
This HotFix modifies the following files on the Administration server computer:
- Accounts.dll
- McsEnumOperations.dll
By default, these files are located in the C:\Program Files\NetIQ\DRA folder.
For more information, please contact Technical Support at www.netiq.com/support.