Contacts are not being created after running EMCLI DIRSYNC. (NETIQKB26425)

  • 7726425
  • 02-Feb-2007
  • 17-Apr-2008

Resolution

fact
Exchange Migrator 1.x

fact
Exchange Migrator 2.x

symptom
Contacts are not being created after running EMCLI DIRSYNC.

cause
The contacts previously created by EMCLI DIRSYNC have been deleted. Since EMCLI DIRSYNC has already been run, the Exchange Migrator database still contains a mapping for these objects and therefore does attempt to create new contacts for the deleted objects.

fix
To resolve this issue and create new Contacts for the deleted objects, run EMCLI DIRSYNC with the /CLEARTABLES switch, so Exchange Migrator will write a new mapping table to the database.  Running with the /CLEARTABLES switch will allow Exchange Migrator to create Contacts for the source DLs since it is using a new table that does not have references to old deleted AD objects.

note

For more information about the syntax and usage of EMCLI DIRSYNC please refer to the following Knowledge Base article:

NETIQKB863 - What is the syntax and usage for EMCLI DIRSYNC?
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB863



Additional Information

Formerly known as NETIQKB26425