Resolution
fact
NetIQ Group Policy Administrator 3.0
fact
NetIQ Group Policy Administrator 4.0
fact
NetIQ Group Policy Administrator 4.5
symptom
Unable to connect to the Repository after performing an uninstall/reinstall of the Server.
symptom
The Repository is not available even though it gives the message that it installed successfully.
cause
The cause of this issue is that the Repository database files are not deleted after performing an uninstall of the Repository.
fix
note
NetIQ Group Policy Administrator 3.0
fact
NetIQ Group Policy Administrator 4.0
fact
NetIQ Group Policy Administrator 4.5
symptom
Unable to connect to the Repository after performing an uninstall/reinstall of the Server.
symptom
The Repository is not available even though it gives the message that it installed successfully.
cause
The cause of this issue is that the Repository database files are not deleted after performing an uninstall of the Repository.
fix
When performing an uninstall of the Repository, the Repository database files are not deleted. This is by design and allows a recovery of the Repository information. However, when trying to reinstall the repository, the installation will detect that the GPO_REPOSITORY files are available and the installation will not complete successfully.
To resolve this issue, the GPO_REPOSITORY database must be first manually deleted, and then the Repository can be successfully reinstalled.
To resolve this issue, perform the following.
- Start the Setup.exe on the Repository Server machine and select Begin Setup.
- Select Server and Next.
- Select Remove and Next.
- Click Finish.
- Launch the SQL tool Enterprise Manager.
- Navigate to the Database container and right-click the GPO_REPOSITORY database and select Delete.
- Select Yes on the confirmation "Are you sure you want to delete database 'GPO_REPOSITORY".
- Perform a reinstall of the Repository.
The GPO_REPOSITORY database can also be deleted by:
- Stop the MSSQLSERVER service on the Repository server machine.
- Manually delete GPO_REPOSITORY.mdf and GPO_REPOSITORY_log.LDF files from C:\Program Files\Microsoft SQL Server\MSSQL\Data.
- Start the MSSQLSERVER service.
note
To troubleshoot this issue.
- View the log file in C:\Program Files\NetIQ\Group Policy Administrator\Server . It will contain an error that the install could not take place because the files GPO_REPOSITORY.mdf and GPO_REPOSITORY_log.LDF already exist.
Additional Information
Formerly known as NETIQKB23671