Resolution
fact
Exchange Migrator 2.2 SP1
fact
Exchange Migrator 2.3
symptom
Failed to acquire lock for the project. [YourExchangeServerName] currently holds the lock [HR=0x80004005]
cause
This error has most likely come up because the project is currently being used by another Exchange Migrator (EM) console, or the project lock has not been released since the last migration with that project.
fix
note
Exchange Migrator 2.2 SP1
fact
Exchange Migrator 2.3
symptom
Failed to acquire lock for the project. [YourExchangeServerName] currently holds the lock [HR=0x80004005]
cause
This error has most likely come up because the project is currently being used by another Exchange Migrator (EM) console, or the project lock has not been released since the last migration with that project.
fix
- If there is another Exchange Migrator (EM) console using the project then you will need to wait 15 minutes after the other EM console has completed its migration with that project in order for the project lock to clear.
- If you know that the project lock is invalid (i.e. there are no other EM consoles currently migrating that use this same particular database), then you can manually clear the Projectsession table within the EMA database with Microsoft SQL Enterprise Manager (preferred), or the Microsoft osql utility.
note
Related topic:
- NETIQKB1402 : Can I run multiple Exchange Migrator consoles at the same time?
Additional Information
Formerly known as NETIQKB22651