Scheduled tasks do not run for the migrated user after translating security. (NETIQKB21823)

  • 7721823
  • 02-Feb-2007
  • 08-Sep-2008

Resolution

fact
Domain Migration Administrator 7.x

symptom
Scheduled tasks do not run for the migrated user after translating security.

cause

When you create a scheduled task, the password that is supplied for the task is stored in the Protected Storage database; the password is not stored in the actual task. When you create the scheduled task, the task is given a security descriptor. The task uses this security descriptor to gain access to the Protected Storage database to get the password. If you either move or alter the task, the security descriptor is broken, and the link to the Protected Storage database is broken. Therefore, the task cannot access the password, and the task cannot run. After you translate security in add or replace mode, the 'Run as' field for this task is changed to target\user (This is done by the operating system, not DMA).  On the permissions of the task, both source\user and target\user have Full Control. (This has been done by DMA when you translated security on Files and folders in Add mode).  Right-click the task and select Run, it does not run. The Status is Could not start. This is the status that is displayed if the scheduled task does not have the correct password. The behavior is the same whether the user was migrated by copying the password or creating a new password.  The behavior is the same whether the source accounts are members of the Power Users group on the workstation, or are just normal domain users.



fix

To resolve, please refer to the following:

  1. Verify the account associated with the scheduled task.
  2. Re-enter the password.


note

Please see the following Microsoft Knowledge Base article for more information.

317529 - Scheduled Task Does Not Run After You Push the Task to Another Computer
http://support.microsoft.com/default.aspx?scid=kb;en-us;317529



Additional Information

Formerly known as NETIQKB21823