Error: 'QI for IMailboxStore failed [HR=0x80004002].' (NETIQKB21446)

  • 7721446
  • 02-Feb-2007
  • 07-Nov-2007

Resolution

fact
Exchange Migrator 2.x

symptom
Error: 'QI for IMailboxStore failed  [HR=0x80004002].'

symptom
Error: 'The migration to Exchange 2000 failed. This was caused by an out-of-date version of the Exchange dlls. You must have the Exchange 2000 Management Tools installed on this computer before you can migrate to Exchange 2000. [HR=0x80004002]'

symptom
Error: 'ProcessHelperForMdb... failed to migrate object [/o=Organization/ou=OranizationalUnit/cn=Recipients/cn=NameofMailbox][HR=0x80004002].'

cause

The following are possible causes:

  1. You have selected to migrate the source mailbox that Exchange Migrator is using to run the project.
  2. You have created a project with a test source (from a backup of a production environment) and production target, and you migrate fine.  Then, you rebuild your source the same way (with all of the same names).  If you come back and try to use the same console and same project, you may get this error.
  3. One of the mailboxes that you are migrating has an NT group for its Primary Windows NT account.
  4. You have low virtual memory error messages during a migration.
  5. You are migrating using a console that is on a non-English operating system. Some non-English operating systems require manual registration of the dll CDOEXM.dll.
  6. There are some cases where this could also be a result of a previous manual registration of the CDOEXM.dll or some corruption with the original registration.


fix

To resolve this issue, you can perform one of the following procedures depending on the source of the problem. These procedures correspond to the possible causes listed above.

Exchange Migrator Resolutions:

If either of the following conditions apply, remove the source mailbox from the project:

  • You are migrating the source mailbox that Exchange Migrator is using for the migration
  • You have previously created a test source and rebuilt your source to perform the migration and the migration failed

For more information about removing an object from a project, see the following NetIQ Knowledge Base article:

"How do I remove an object from a project?" at https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB27170

If you are attempting to migrate a mailbox that has an NT group as its Primary NT Account, see the following NetIQ Knowledge Base article:

"Can I migrate a mailbox with an NT group as the primary windows NT account?" at https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB7587

If you are having problems with low virtual memory, increase your virtual memory settings.

CDO Registration Resolutions:

If you are migrating using a console installed on a computer with a non-English OS, register the CDOEXM.dll located in \Exchsrvr\bin on the Exchange Migrator console machine.  The command to register the dll is:

regsvr32 "c:\program files\exchsrvr\bin\cdoexm.dll"

(Substitute \\ for \ for non-English directory separators)

If you do not have a non-English client, it is recommended that you DO NOT manually register CDOEXM. Instead, use the following Microsoft VBScript to verify the functionality of CDO on the Exchange Migrator console. If this script does not execute correctly, the issue is likely due to CDO registration errors.

"327079 - How to programmatically create a mailbox for an existing user in the Active Directory by using CDOEXM" at http://support.microsoft.com/default.aspx?scid=kb;en-us;327079&Product=exch2003

WARNING: Do not follow this procedure if the EM console is installed on an actual Exchange Server.  If this is the case, consult Microsoft before attempting to clean the CDOEXM.dll registration.

  1. Delete any CDOEXM.dll related registry keys that point to locations of CDOEXM.dll other than exchsrvr\bin. Typically the CDOEXM.dll registration keys can be found in the following location:

    HKCR\CLSID\{25150F1F-5734-11D2-A593-00c04f990d8a} through {25150F27-5734-11D2-A593-00c04f990d8a
  2.  
  3. Uninstall the Exchange System Manager and reboot the EM console.
  4. Reinstall the Exchange System Manager.

If this script executes correctly and the other suggested workarounds do not address your issue, please contact NetIQ Technical Support.



Additional Information

Formerly known as NETIQKB21446