Application log on a Directory and Resource Administration server contains an error when trying to p (NETIQKB20528)

  • 7720528
  • 02-Feb-2007
  • 19-Jun-2007

Resolution

fact
Directory and Resource Administrator 6.60

fact
Directory and Resource Administrator 7.x

symptom
Application log on a Directory and Resource Administration server contains an error when trying to push an agent to a domain controller.

symptom
Error: "Event ID 13624. Error: Failed to get agent registration hr=80010001."

symptom
Using EAAgentUtil to issue command, "EAAgentUtil /status DC_Name" generates an error followed by an HR=80010001, which translates to 'Call rejected by callee'.

cause
The issue can be caused when DCOM is not enabled on the domain controller that Directory and Resource Administrator is trying to push an agent to.

fix

To resolve this issue, enable DCOM on the target domain controller:

  1. On the domain controller, click Start | Run.

  2. Enter DCOMCNFG on the run line, and click OK.
  3. Click the Default Properties tab.
  4. Make sure the box is checked for Enable distributed COM on this computer.
  5. If it was previously not enabled, you will need to reboot the domain controller to make this new setting take effect.


Now the agent should be uninstalled and reinstalled on that domain controller:

  1. Open a command prompt on the Directory and Resource Administrator (DRA) server and change to the directory, .\Program Files\NetIQ\DRA.
  2. Run the following command:

    EAAgentUtil /uninstall DC_Name Domain_Name\Admin_Account

  3. Enter the password that goes with the admin account when prompted.
  4. After the message that the uninstall was complete, run the following command:

    EAAgentUtil /install DC_Name Domain_Name Domain_Name\Admin_Account

  5. Enter the password that goes with the admin account when prompted.


Additional Information

Formerly known as NETIQKB20528