Resolution
Why does a Resources import take a long time to complete?
fact
Directory and Resource Administrator 6.x
fact
Directory and Resource Administrator 7.x
symptom
Resource import (Services, Devices, Shares, Printers, or Event Logs) takes a long time to complete.
symptom
Imports appear to hang.
cause
This issue is a result of the selected import options. When making selections on the Resources tab, the following options are available:
- Computers
- Services
- Devices
- Shares
- Printers
- Event Logs
Selecting the Computers option causes the import process to build a list of all computer accounts in the security database but does not attempt to contact the physical machines. To import any of the other five types of resource information (Services, Devices, Shares, Printers, and Event Logs), the Reporting tool must contact each machine individually. Any machines that are located across a slow WAN connection will cause the import to take an extended period time to finish. If the machines for any computer accounts in the domain are offline or if they do not exist, the import process must wait for the call to that machine to time out before it can continue with the next one.
cause
This issue can also be caused by a slow connection to a distant domain controller for a managed Windows NT4 domain. Directory and Resource Administrator (DRA) connects to the PDC of a Windows NT4 domain, by default, and does not use the nearest domain controller, as it does for a Windows 2000 domain. If the PDC for the managed domain is remote and across a slow WAN link, the reporting tool may take an extended period of time to import the requested information from it.
fix
Awareness of the purpose of each import option is the key to performing an efficient import. To optimize the import of resource information, select the Computers option only. If information from the other resource types is required, select the option to import from one specific domain only in the Domain Selection tab. This will reduce the number of computers that must be contacted to retrieve the information. Lastly, perform an import to gather resource information from the target machines during the workday when the greatest number of them will be online and available.
fix
Run a reporting import on a DRA server in close proximity to the PDC of a managed NT4 domain whenever possible. Once that domain is upgraded to Windows 2000, more domain controllers will be available for DRA to connect to and can deliver the information quickly to different DRA servers.