System Uptime Knowledge Script generates the Error: 'Can't get System Up Time Counter'. (NETIQKB19622)

  • 7719622
  • 02-Feb-2007
  • 02-Dec-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

System Uptime Knowledge Script generates the Error: 'Can't get System Up Time Counter'.
Error: 'Can't get System Up Time Counter'.

Resolution

You must ensure the SYSTEM\System Up Time counter on the agent computer is available and accessible by the AppManager Agent.

To correct this issue:

  1. Verify if the Windows Performance Monitor counter SYSTEM\System Up Time is available on the agent computer.
    1. Open the Windows Performance Monitor utility (PERFMON.EXE).
    2. Select the object System and counter System Up Time.
    3. Reload the Performance Monitor counters, if the counter SYSTEM\System Up Time is not present on the computer.
  2. Ensure the AppManager agent can properly access the counter, if the counter SYSTEM\System Up Time is present on the computer.
    1. Stop all jobs on the server.
    2. Delete the SystemUptime job.
    3. Add the server again to the NT_SystemUptime parent job or drop a new NT_SystemUpTime job.
    4. Restart all the other jobs on the server.
  3. Reinstall the Performance counter, if the previous options did not correct the issue.

The following Microsoft KnowledgeBase article link provides instructions on reinstalling counters:
http://support.microsoft.com/default.aspx?scid=kb;en-us;300956

Cause

The Microsoft Windows Performance Monitor counter SYSTEM\System Up Time cannot be properly accessed by the AppManager Agent.

Additional Information

Formerly known as NETIQKB19622

For more information about restoring the counter or granting appropriate permissions, contact Microsoft Technical Support.