Resolution
fact
Exchange Migrator 2.x
symptom
Warning - Failed setting property 'member' on object [CN=Distribution List,CN=Users,DC=domain,DC=company,DC=com] [HR=0x80070002]
cause
Error code 80070002 translates to the system cannot find the file specified. This is the result of an inaccurate Exchange Migrator database entry. When objects are migrated, the fully qualified LDAP path to the source and target objects are stored in the Exchange Migrator database (EMA). If the object is moved or renamed after migration, this path will be inaccurate. This causes issues with the completion of mailbox migration if the object is renamed using a script during the migration. It can also cause issues with DL membership updates during DL migration, as well as incomplete permission updates processed during the Synchronize and Update Migrated Mailboxes wizard.
fix
note
note
Exchange Migrator 2.x
symptom
Warning - Failed setting property 'member' on object [CN=Distribution List,CN=Users,DC=domain,DC=company,DC=com] [HR=0x80070002]
cause
Error code 80070002 translates to the system cannot find the file specified. This is the result of an inaccurate Exchange Migrator database entry. When objects are migrated, the fully qualified LDAP path to the source and target objects are stored in the Exchange Migrator database (EMA). If the object is moved or renamed after migration, this path will be inaccurate. This causes issues with the completion of mailbox migration if the object is renamed using a script during the migration. It can also cause issues with DL membership updates during DL migration, as well as incomplete permission updates processed during the Synchronize and Update Migrated Mailboxes wizard.
fix
To resolve, please refer to the following:
- Undo the object migration using the Undo Mail Object Migration wizard.
- NETIQKB7637 - What is the best practice for performing an undo in an Exchange 5.5 to Exchange 2000 migration
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB7637 - If the error was Failed setting..'member':
- Turn on Diagnostic Logging.
- NETIQKB2201 - How do I increase logging for Exchange Migrator?
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB2201 - ReMigrate the object.
- There will now be a log in the \Program Files\NetIQ\Exchange Migrator\Logs directory called EMDevlog.txt. This log file will contain a list of all the members of the DL just prior to the error message.
- Open the EMDevlog file and search for the phrase propertyName [BSTR='member'].
- Below that you will see a list of all of the members of that DL. If the member is listed as Translated Ref then the member has been migrated. That line will contain the path as it appears in the Exchange Migrator database. This path must accurately represent the path to the target object. If the path for ANY single member of the DL is inaccurate the entire membership update will fail.
- Undo the DL Migration.
- Open the EMA database using SQL Enterprise Manager.
- Return All Rows on the MigrationInfo table.
- Locate the object with the incorrect path.
- Update the object path to correctly represent the target object. NOTE: If you add characters when updating the value, you must delete an equal number of blank spaces from the end of the line.
- Close SQL Enterprise Manager.
- If the error was Failed setting...'member', re migrate the DL that produced the error.
- If the error was Failed getting object properties, re migrate the object that produced the error.
note
If you are using MSDE you can use OSQL commands rather than the SQL Enterprise Manager. For more information on OSQL please refer to Microsoft.
Transact-SQL Overview - http://msdn.microsoft.com/library/default.asp?url=/library/en-us/tsqlref/ts_tsqlcon_6lyk.asp
note
For more information on converting error codes please refer to the following Knowledge Base article:
NETIQKB12338 - How to convert into text the error return codes found in a log.
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB12338
Additional Information
Formerly known as NETIQKB18529