DRA is unable to list open files on a Network Appliance Filer system. (NETIQKB13735)

  • 7713735
  • 02-Feb-2007
  • 19-Jun-2007

Resolution

fact
Directory and Resource Administrator 6.x

fact
Directory and Resource Administrator 7.x

symptom
DRA is unable to list open files on a Network Appliance Filer system.

cause

The cause of this particluar issue is due to the way the Net App NetFileEnum API call handles a large amount of open files.  Basically, the response is limited to 256Kb and, once that is met, the API call would report that there was more info available.   DRA does not handle the more info error.



fix
This has been addressed In version 6.3 of the Net App software.  The developers removed their change that limited the response, so once the customer upgrades to 6.3, DRA will work.  However, NA states that if there are a large number of open files, the response could get very large and thus would require a lot of memory.  If the response gets too large and the filer runs out of memory, an error will be returned.  Network Appliance has stated that this would not cause the server to hang or crash.  Simply making this memory available for this purpose reduces the amount available for other requests, and could theoretically cause some performance impact while other requests wait for memory to be available.

Additional Information

Formerly known as NETIQKB13735