Discovery_Web-RT Knowledge Script fails. (NETIQKB13669)

  • 7713669
  • 02-Feb-2007
  • 17-Aug-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
NetIQ AppManager Response Time for Web Module (Web-RT)

Situation

Discovery_Web-RT Knowledge Script fails.
Error: The "Class = WebEngine.ActiveWebEngine" member is invalid or the ResponseTime module is not installed properly.

Resolution

When running the Discovery_Web-RT Knowledge Script the managed client on which the script is run must have a user logged into the computer.

Note you can lock the computer to prevent access to it, but a user must be logged on. Additionally the logged on user must have a valid Internet Explorer profile (i.e. the user must have started and gone through the initial connection wizard that prompts for connection settings). Without the successful completion of the setup wizard, Web-RT will not be able to reach the Internet to test your scripts.

This limitation is due to the fact that Internet Explorer is not designed to run without a currently logged in user. If you attempt to run without a user logged in, you may notice several anomalies.

Cause

This error is typically caused when a required user is not logged on locally to the agent machine running the Discovery_Web-RT knowledge script.

Additional Information

Formerly known as NETIQKB13669

If currently running other Webservices knowledge scripts on the target agent machine while installing the Web-RT module please stop these jobs during this install and Discovery_Web-RT period.

This target agent machine must be logged in locally, logging in via terminal server or other remote administration tool will not work.

The Netiq AppManager Client services on the target Web-RT agent machine must be logged in (run as) as the LocalSystem account.