DiagnosticManager keeps losing connectivity to the database server. (NETIQKB12254)

  • 7712254
  • 02-Feb-2007
  • 11-Feb-2008

Resolution

fact
DiagnosticManager for SQL Server 1.x

fact
DiagnosticManager for SQL Server 2.x

symptom
DiagnosticManager keeps losing connectivity to the database server.

cause
DiagnosticManager issues a network ping to all servers that it monitors before it connects. If the ping does not come back for any reason, then DiagnosticManager will report the server as unreachable. However, sometimes the ping failure is due to transient network latency that may not affect other SQL Server tools (e.g. SQL Enterprise Manager).

fix

To resolve this issue, please refer to the following steps:

  1. Uncheck the Use Network Ping option from the 'Global Settings' screen.
  2. Create an alias:
    1. From the DiagnosticManager machine click Start | Run and type cliconfg to open the 'SQL Server Client Network Utility' properties box.
    2. Select the Alias tab.
    3. Click Add and enter an alias using the following format ("ServerNametcpip") in the 'Server alias' box.
    4. Select the TCP/IP radio button. 
    5. Enter the TCP/IP address in the 'Server name' box.
    6. Click OK from the 'Edit Network Library Configuration properties' box.
    7. Click OK from the 'SQL Server Client Network Utility' properties box.


Additional Information

Formerly known as NETIQKB12254