Error: 'TryLogon() failed.  Leaving loop. [HR=0x8004011c]'. (NETIQKB11651)

  • 7711651
  • 02-Feb-2007
  • 02-Oct-2007

Resolution

fact
Exchange Migrator 1.x

fact
Exchange Migrator 2.x

symptom
Error: 'TryLogon() failed.  Leaving loop. [HR=0x8004011c]'.

cause

The following are possible causes of this error:

  • Microsoft Exchange 2000 Recipient Update Service (RUS) replication
  • DNS name resolution
  • The account being used for migration does not have the required permissions on the target Exchange environment
  • Incorrect version of MAPI32.dll
  • Microsoft Exchange Information store crashes
  • Exchange Migrator is trying to merge on a disabled mail-enabled user account 


fix
The following are possible resolutions for this error:

  • Ensure the that Recipient Update Service (RUS) is replicating in your environment successfully.
    • One test for the RUS replication issue is using native tools to create a brand new mailbox on the target and then log into it immediately.  If you are unable to log in immediately after the creation of the mailbox, you should gather information such as error messages, and how much time is needed before you are able to log in.

  • Ensure that DNS and NetBIOS name resolution is in order.

  • Please refer to the following knowledge base article to confirm you have all of the Exchange Migrator pre-requisites:

    What are the software and configuration requirements for Exchange Migrator?

    https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB2202


  • For Exchange 2000/2003 Target: Confirm that you have version 6.x of the MAPI32.dll in the c:\winnt\system32 directory. You can typically copy this version of this dll from the exchsrv\bin directory on the local machne.
  • Alternatively, you can use the MAPI32.dll file from the Exchange 2000 SP2 CD or the Exchange 2003 CD, if possible. After you change this, create new MAPI profiles per the above knowledge base article (NETIQKB2202).

    Note:
    If you open Microsoft Outlook 2000 or Outlook XP after you change the version of the Dll, it will eventually pop up a warning stating that Outlook has found something wrong and it will ask you if you would like Outlook to fix itself. If you choose yes, then Outlook will automatically replace the MAPI32.dll version with the 1.0 version.



note

For related information please refer to the following Knowledge Base article:



Additional Information

Formerly known as NETIQKB11651