A new Exchange mailbox is not created when cloning a template user account that has en existing mail (NETIQKB11495)

  • 7711495
  • 02-Feb-2007
  • 14-May-2007

Resolution

fact
Directory and Resource Administrator 6.40

symptom
A new Exchange mailbox is not created when cloning a template user account that has en existing mailbox.

symptom
When cloning a template user account with a valid mailbox assigned, the new user account is created but the mailbox is not.  This situation occurs infrequently but when it does, it affects all Assistant Admins. 

cause

When the 'MCS OnePoint Administration Server' service initializes, the Exchange Provider and the Accounts Provider attach to a domain controller to read property information from and write changes to.  If the original domain controller becomes unavailable, the Accounts provider attaches to the next closest domain controller as reported by the Domain Cache Refresh.  The Exchange provider does not.

When a new account is created and mail-enabled, at the same time, the account is created and then the Exchange provider references it to set the primary account for the mailbox.  Because the Exchange Provider did not update it's domain controller connection, it is referencing a domain controller to which the new account has not been replicated.  This prevents the Exchange Provider from creating the mailbox as needed.



fix
This issue is corrected by stopping and then restarting the MCS OnePoint Administration Server service.

note
This behavior was corrected in Directory and Resource Administrator versions 6.5 and later.  The Exchange provider connects to the same domain controller the accounts provider connects to when the Domain Cache Refresh updates this information.

Additional Information

Formerly known as NETIQKB11495