Error: 'Unable to add the secondary server. The primary server primary_name could not find the seco (NETIQKB10394)

  • 7710394
  • 02-Feb-2007
  • 21-Mar-2013

Environment

NetIQ Directory and Resource Administrator 8.x

Situation

When attempting to add a secondary Directory and Resource Administrator (DRA) server to an existing multi-master set, the following error may occur:

Unable to add the secondary server. The primary serverprimary_name could not find the secondary server secondary_name.

The DRA server failed to open the DRA registry sub-tree on the secondary. This failure can occur if the DRA server is not installed on the secondary. It can also happen if the access account you defined is either invalid or does not have proper permissions to access the secondary's registry.

Resolution

To resolve this issue:

  1. Ensure that the secondary DRA Server name is spelled correctly in the MMS Configuration Wizard
  2. Ensure that the NetIQ DRA Administration Service is set to Automatic Startup and is currently started, on the Secondary DRA Server
  3. Ensure that the Secondary DRA Server is configured as a Secondary DRA Server
  4. Launch the DRA Delegation and Configuration Console
    1. Run the DNC console locally on the Secondary DRA Server as the AD Account Running the NetIQ Administration Service (DRA Service Account)
    2. Connect the Console to the Secondary DRA Server
    3. Expand the Configuration Management Node
    4. Highlight the Administration Servers Object
    5. Verify the Secondary Server’s Mode is listed as Secondary
  5. Use Windows Regedit on the Primary DRA Server to connect to the Network Registry of the Secondary DRA Server
    1. Launch Regedit locally on the Primary DRA Server under the context of the DRA Service Account of the Primary Server, or the Access Account used in the MMS Configuration Wizard
  6. Verify that the PING command can ping the Secondary DRA Server by its NetBIOS Name (Short Name) and its FQDN from the Primary DRA Server

Cause

There are multiple issues that can cause DRA to display this error message:

  1. The DRA Sever name entered into the MMS configuration wizard is an invalid DRA Server
  2. The DRA Server name is a valid DRA Server name and the NetIQ DRA Administration Service is stopped
  3. The DRA Server name is a valid DRA Server and it is not configured as a secondary DRA Server
  4. The DRA Service Account, or Access Account specified in the MMS configuration wizard, does not have remote network access to the Windows Registry on the secondary DRA Server’s OS
  5. The DRA Server name is valid, but does not respond to a network ping command by the NetBIOS and Fully Qualified Domain Name (FQDN) of the DRA Server; when pinged from the Primary DRA Server

Additional Information

Formerly known as NETIQKB10394