Cim_FanSummary script events "status for fan is not supported" (NETIQKB10181)

  • 7710181
  • 02-Feb-2007
  • 17-Aug-2010

Environment

NetIQ AppManager for Compaq CIM/HP SIM (all versions)
Compaq DL 760 Servers with Smartstart 5.3
Compaq DL 760 Servers with Smartstart 5.4

Situation

Cim_FanSummary script events "status for fan is not supported"

Resolution

fix

  1. Verify that Fan Status has been enabled for monitoring from Compaq Insight Manager if supported for this version of hardware / software.

  2. Use the CIM_FanIndividual Knowledge Script. This also monitors the CPU fans but has the different OID numbers to call for the CPU information.  This script gathers granular status information for each fan object discovered on the agent machine. 

  3. Use the CIM_Integratedlog Knowledge Script for monitoring fan errors reported by CIM.  This will provide overall CIM errors for the agent machine.

  4. Reinstall the CIM agent if you believe this is supported on this exact hardware and you see other agents returning a correct response code

    for this OID .1.3.6.1.4.1.232.6.2.6.5.0.  Use SMNPTool.exe from the Windows Resource Kit to get this OID string.  A return code of "1" for OID .1.3.6.1.4.1.232.6.2.6.5.0 or .1.3.6.1.4.1.232.6.2.6.4.0  will use the script logic:
    Case "1" ' other MCAbort resmsg, "Getting status for fan is not supported"

  5. Contact Compaq or consult your Compaq documentation for more information about these particular OID strings.

  6. CIM supported versions for AppManager are listed:

    https://www.netiq.com/support/am/supportedproducts.asp 

    The support list does not mean that every script will work on every hardware version this support is typically controlled at the vendor's hardware level.  This simply means that the base agent will install and discover with AppManager.



Cause

Fan Status has not been enabled for monitoring from Compaq Insight Manager, or is not supported for this version of hardware / software.

Additional Information

Formerly known as NETIQKB10181