Environment
NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
NetIQ Management Server
Situation
Unable to re-register NetIQms.exe.
Resolution
The AppManager Management Server version should correlate with the existing AppManager Repository version. Ensure that the correct version of the AppManager Management Server is installed.
To verify the AppManager Repository (QDB) version:
- Start Query Analyzer from the Microsoft SQL Server programs menu.
- Run the following query against the Version table in the QDB database:
Select version, machinename from version where component='Repository'
If the version are correct then review the SQL Server Logs and Look for Error 18456. This indicates a login failure for SQL.
Compare the State and Severity to the following error codes from this MSDN Blog.
http://blogs.msdn.com/b/sql_protocols/archive/2006/02/21/536201.aspx
Cause
The AppManager Management Server (NetIQms.exe) is not compatible with an AppManager Repository (QDB) database of a different version.
or
There is a SQL Server Login Error preventing the Management Service from authenticating to the QDB.
Additional Information
When registering a Management Server, if you are using the -ur switch to preserve the RPCKey value for Encrypted UNIX communication, you should use the -ur switch prior to the -i switch.
Example:
C:\> NetIQMS -r QDBMS:QDB:Username:Password:MSServerName -ur -i