Discovery_NT Knowledge Script does not Discover Multiple Network Interface Cards (NICs) Properly (NETIQKB7699)

  • 7707699
  • 02-Feb-2007
  • 26-Jul-2010

Environment

AppManager Suite 6.x
AppManager Suite 7.0.x
Microsoft Windows 2000 Server

Situation

Discovery_NT Knowledge Script does not Discover Multiple Network Interface Cards (NICs) Properly

Resolution

To verify these counters exist and are accessible via Windows Performance Monitor:

  1. Launch Performance Monitor. (perfmon or Administrative Tools -> Performance)
  2. Click Add.
  3. Choose Select Counters From Computer.
  4. Enter the host name of the Server being monitored (\\ComputerName).
  5. Select the appropriate Object from the Performance Object list.
  6. Choose Select Counters From List.
  7. Select the Counter to verify.
  8. Choose Select Instances From List.
  9. Select the appropriate Instance.
  10. Click Add. This will verify that the counter exists and is accessible.

Cause

To discover a Network Interface Cards (NIC), the Discovery_NT knowledge script requires access to the following counters:

Object: Network Interface
Counter: Bytes Received/Sec
Counter: Bytes Sent/Sec
Counter: Bytes Total/Sec
Instance: <Network Interface Card>

Additional Information

Formerly known as NETIQKB7699

If the specified counters are inaccessible or corrupt (not able to retrieve data), restore the Microsoft Windows Performance Counters by applying Microsoft's newest Service Pack and/or contacting Microsoft Technical Support.

To view further documentation from Microsoft's web site about "Corrupted Performance Counters May Disappear or Be Unavailable to Perfmon (Q275659)" please access the link provided below:

Corrupted Performance Counters May Disappear or Be Unavailable to Perfmon (Q275659)
http://support.microsoft.com/default.aspx?scid=kb;en-us;275659