Resolution
fact
Domain Migration Administrator 6.x
fact
Domain Migration Administrator 7.x
symptom
Error: 'The specified domain either does not exist or could not be contacted. (error code 54b, domain=source_domain)'.
symptom
An error is received after selecting source and target domains for the drop-down lists and clicking next, when creating a project.
cause
This is usually a result of name resolution issues within the network related to WINS or DNS. The DNS and WINS name resolution services must be in place and properly functioning to successfully use Domain Migration Administrator. DNS service problems are one of the most common problems encountered when attempting to migrate from domain to domain. Rigorously check and verify your DNS services before migrating to prevent many problems and frustrations.
fix
note
Domain Migration Administrator 6.x
fact
Domain Migration Administrator 7.x
symptom
Error: 'The specified domain either does not exist or could not be contacted. (error code 54b, domain=source_domain)'.
symptom
An error is received after selecting source and target domains for the drop-down lists and clicking next, when creating a project.
cause
This is usually a result of name resolution issues within the network related to WINS or DNS. The DNS and WINS name resolution services must be in place and properly functioning to successfully use Domain Migration Administrator. DNS service problems are one of the most common problems encountered when attempting to migrate from domain to domain. Rigorously check and verify your DNS services before migrating to prevent many problems and frustrations.
fix
To resolve verify Name Resolution Services:
- Domain names must be unique. Domain Migration Administrator does not support migrating between two domains whose DNS or NetBIOS names are identical.
- You can also use the
DNScmd
utility to help identify and resolve DNS-related issues.
To verify DNS is working properly:
- Verify every domain controller IP address is in the DNS forward and reverse lookup zones. Make sure there are no missing or unnecessary host records.
- Verify that the secondary DNS server has replicated every change in both the forward and reverse lookup zones. Make sure there are no missing or unneeded records.
- On the primary DNS server, stop and restart the DNS Server service, then stop and restart the DNS Client service. Repeat this process for the secondary DNS server.
- Use the
NSLOOKUP
command at theprimary and secondary DNSservers to verify that the host name and IP address of the computer where you will install Domain Migration Administrator are both resolved properly. For more information about theNSLOOKUP
command, see the Windows NT or Windows 2000 documentation. - Use the
NSLOOKUP
command at the computer where you will install Domain Migration Administrator to verify that the primary and secondary DNS servers, the Global Catalog server, and all five FSMO role servers are properly resolved for both host name and IP address. - Use the
NSLOOKUP
command on all other domain controllers involved in the migration to verify the primary and secondary DNS servers are properly resolved for both host name and IP address. - For best results, switch your source PDC to register in and point to your Windows 2000 domain DNS and WINS servers.
note
For more information about installing and implementing DNS, see
- Microsoft article Q301192, How To Migrate an Existing Domain Name System Infrastructure from a BIND-Based Server to a Windows 2000-Based Domain Name System Server in Windows 2000, at http://support.microsoft.com/default.aspx?scid=kb;en-us;301192
- Chapter 2 of the Domain Migration Administrator User Guide
Additional Information
Formerly known as NETIQKB7294