NT_CPULoaded Knowledge Script errors with Failed on CPU MO (NETIQKB6969)

  • 7706969
  • 02-Feb-2007
  • 17-Nov-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

NT_CPULoaded Knowledge Script errors with Failed on CPU MO
NT_MemUtil Knowledge Script errors with Failed on Counter/Memory MO
RErr4101(L72):Failed on CPU MO
RErr4103(L103):Failed on Counter/Memory MO

Resolution

Since these scripts are counter based, please verify the counters through the performance monitor.
On the target machine, go to START > RUN and type PERFMON <ENTER>
Check to see if a graph can be created for the Performance Object "MEMORY" and "PROCESSOR." If you see valid counter graphs, then make sure that disk performance is enabled upon bootup.

If the counters are working properly, run a new Discovery_NT Knowledge Script on the target machine first, then drag and drop a new NT_CPULoaded Knowledge Script onto the machine. If the Knowledge script still fails to run properly, then verify if the counters are enabled by typing "diskperf \\<servername>" from a command prompt.

This will give a message stating whether they are enabled or not. (i.e. Disk Performance counters on \\servername are currently set to start at boot.) If disk performance is not enabled, they will have to enable it by typing "diskperf -y" in the DOS command prompt on the agent machine. (This will require a reboot to fully enable them).

Once the reboot is complete, drag and drop a new Discovery_NT knowledge script first, and then drag and drop a new NT_CpuLoaded Knowledge Script.

Cause

This error event message can occur when the Performance Counters are either corrupt or not being loaded on the target machine.

Additional Information

Formerly known as NETIQKB6969