The %username% value specified in the 'Terminal Services Profile Path' field does not get resolve to (NETIQKB6175)

  • 7706175
  • 02-Feb-2007
  • 19-Jun-2007

Resolution

fact
Directory and Resource Administrator 6.30.01

fact
Directory and Resource Administrator 6.40

fact
Directory and Resource Administrator 6.50

fact
Directory and Resource Administrator 6.60

symptom
The %username% value specified in the 'Terminal Services Profile Path' field does not resolve to the account name.

symptom

If an Assistant Admin updates the 'Profile Path' field on the 'Terminal Services' tab in the 'User Accounts Properties' page with %username% in the path, the %username% does not get resolved to the user's name.



cause
Directory and Resource Administrator does not attempt to resolve the %username% to a value when specified in the 'WTS Profile Path' field.  The %username% value is resolved to the username when specified in the 'Home Directory Path'.

fix

This behavior has been modified in Directory and Resource Administrator (DRA) 6.50 and later.  DRA 6.50 and later resolves the %username% value when specified in the 'Terminal Services Profile Path' field.  In order to resolve this issue download and upgrade to the latest version.

If you are running Directory and Resource Administrator 6.40 and earlier a pre-task trigger can implemented as a workaround to resolve the %username% value in the 'WTS Profile Path' field.  A sample trigger script is available in the DRA Software Development Kit (SDK), which can be used to resolve the %username% value.  For more information on this script, please refer to the "Using SAM Account Name in the WTS Profile Path" topic under the Developing Custom Policies and Automation Triggers | Sample Policy and Automation Trigger Scripts section in the DRA SDK



note

For more information on the Directory and Resource Administrator Software Development Kit, please refer to the following Knowledge Base article:

 



Additional Information

Formerly known as NETIQKB6175