AppManager Operator Console performance is very slow. (NETIQKB5257)

  • 7705257
  • 02-Feb-2007
  • 03-Nov-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
NetIQ AppManager Repository

Situation

AppManager Operator Console performance is very slow.
There are many records in the DATAREJECTED table
The Microsoft SQL server does not have sufficient resources to monitor the environment.
When starting the Operator Console, Events come up quickly, but AppManager jobs take much longer to load.
In the Operator Console, under Troubleshooter > Management Service Info > Statistics the PIOC files are showing full

Resolution

Allow the SQL server jobs to catch up with the data header creation task:

  1. Turn off the NetIQ Appmanager Management Server service.
  2. Do a select statement on the Data Rejected Table.

    USE QDB
    select count(*) from datarejected

  3. Open SQL Enterprise Manager from the ' Start > Programs > Microsoft SQL server > Enterprise Manager'
  4. Browse to the following folder within the SQL Enterprise Manager Treeview 'Console Root > Microsoft SQL server > SQL Server Group > "instance name" > Management > Sql Server Agent > Jobs'
  5. Manually execute the  NetIQ minutely task by right clicking and selecting 'start job'.
  6. Do a select statement on the Data Rejected Table:

    USE QDB
    select count(*) from datarejected

  7. The count should should be lower than the original select statement in step 2.
  8. Allow a minute and then do step 5-7 until the datarejected table is clear or the Minutely task runs by default every 5 minutes so allow sufficient amount of time for the data headers to be created.
  9. Restart the NetIQ Appmanager Management Service.

(Note: The run time for each job can range from 30 seconds to several hours, depending on how long the SQL jobs have been failing and how much data in the datarejected table needs to be processed.)

Cause

Data is being inserted into the repository by the management server service, and the data streams do not have header information to be inserted into the DataHeader table.  This is caused when the Repository server does not have sufficient resources to process the data headers for the incoming data.  The data is then placed in the datarejected table.  The NetIQ Mminutely QDB task scans the DataHeader table every 5 minutes to see if the missing Data Headers for the data sitting in the datarejected table has been processed into the DataHeader table yet.  If it has, the NetIQ Minutely QDB task moves all data that is tied to those headers from the datarejected table, and into the Data table.

Additional Information

Formerly known as NETIQKB5257