Knowledge Scripts scheduled to run once remain in running state (NETIQKB5019)

  • 7705019
  • 02-Feb-2007
  • 02-Dec-2010

Situation

Knowledge scripts that are scheduled to run once on an agent remainin in a Running (Active) state indefinitely.

Resolution

To test connectivity between the AppManager Management Server and the target AppManager Managed Client:

  1. Start the AppManager Operator Console.
  2. Go to Extensions | NetIQctrl.
  3. Type:

             trip <mc_host> netiqmc <ms_host>

    Where:

             MC_host is the hostname of the Managed Client
             MC_host is the hostname of the Management Server

  4. Press Enter. This should return five lines; none of these lines should have a zero. For example, to test connectivity between the agent TEXAS and the Management Server DAYTONA:

NetIQctrl> trip texas netiqmc daytona

                    1289346721  - ctrl
                    1289346721  - mc <texas>
                    1289346721  - ms <daytona>
                    1289346721  - mc <texas>
                    1289346721  - ctrl

If communication is verified using TRIP, Verify the local status of the specific job by using the Profile command from NetIQctrl. The output will provide a list of Running or Stopped jobs on the target Server. If the knowledge script is listed as Running, then either Close or Stop the corresponding job in the AppManager Operator Console. If the knowledge script is listed as Stopped, then the connectivity between the AppManager Management Server and the target Server may need to be investigated further (be sure to check the availability of the appropriate ports if the target Server is on the other side of a firewall).

Cause

Typically, this is a communications or name resolution issue from the target agent to the AppManager Management Server where the knowledge script has stopped running on the agent, but the agent is unable to communicate the job status change information back to the AppManager Management Server.

Additional Information

Formerly known as NETIQKB5019

If network connectivity issues are encountered, as potential work-arounds, consider either creating a Host File on the agent(containing the host name and IP Address of the AppManager Management Server) or by using the AMAdmin_ConfigSiteCommType knowledge script to set the Communication type to Name or IP. 

To properly monitor AppManager Managed Clients outside of a firewall after installation is complete, the following ports need to be open (default ports): 9999 9998 NOTE: Other ports may be required during remote installation or for use of command line utilities. fix For more information about changing the default ports used by AppManager, refer to the following Article: NETIQKB3307