The OnePoint database is marked 'Suspect'. (NETIQKB4993)

  • 7704993
  • 02-Feb-2007
  • 29-Jan-2008

Resolution

fact
Security Manager 4.X

fact
Security Manager 3.X

fact
Security Manager 5.X

symptom
The OnePoint database is marked 'Suspect'.

symptom
LogManagerSummary database is marked 'Suspect'

symptom
LogManagerConfiguartion database is marked 'Suspect'

symptom
The daily log archival (LM) database is marked 'Suspect'

cause

Microsoft® SQL Server? returns error 1105 and sets the status column of sysdatabases to suspect if SQL Server is unable to complete recovery on a database because the disk drive no longer has any free space. Follow these steps to resolve the problem:

  1. Execute sp_resetstatus.
  2. Use ALTER DATABASE to add a data file or log file to the database.
  3. Stop and restart SQL Server.  With the extra space provided by the new data file or log file, SQL Server should be able to complete recovery of the database.
  4. Free disk space and rerun recovery.
  5. sp_resetstatus shown below, turns off the suspect flag on a database but leaves all other database options intact.


fix

Note: Because this procedure modifies the system tables, the system administrator must enable updates to the system tables before creating this procedure.

  1. To enable updates, use this procedure:

    USE master
    GO
    sp_configure 'allow updates', 1
    GO
    RECONFIGURE WITH OVERRIDE
    GO
  2. The following procedure will turn off the suspect flag on the OnePoint database and needs to be executed by a system administrator.  You can replace any database name instead of OnePoint:

    sp_resetstatus OnePoint

    This will result in:

    Database 'OnePoint' status reset!
  3. After the procedure is created, immediately disable updates to the system tables:

    sp_configure 'allow updates', 0
    GO
    RECONFIGURE WITH OVERRIDE
    GO

Always shut down SQL Server immediately after executing this procedure.

WARNING: You must reboot SQL Server prior to accessing this database!



note
CAUTION:  Use sp_resetstatus only when directed by your primary support provider or as recommended in Troubleshooting.  Improper use may damage the database.

Additional Information

Formerly known as NETIQKB4993