Error: 'DBExists error #7 (or #8)' occurs during a console install or uninstall. (NETIQKB4123)

  • 7704123
  • 02-Feb-2007
  • 08-Sep-2008

Resolution

fact
Exchange Migrator 2.x

fact
Exchange Migrator 1.x

symptom
Error: 'DBExists error #7 (or #8)' occurs during a console install or uninstall.

symptom
Error: 'DBExists error #7. Please contact NetIQ'.

symptom
Error: 'DBExists error #8. Please contact NetIQ'.

symptom
DBExists error appears when installing or uninstalling a console.

symptom

The following error messages appear as pop-up screens (or windows) during a console install or uninstall:

  • 'DBExists error #8. Please contact NetIQ'
  • 'DBExists error #7. Please contact NetIQ'


cause

Possible causes for the error messages include the following:

  • The samAccountName of the account performing the install has a hyphen in the name.  Example: a-username
  • Exchange Migrator is installed on a machine that has multiple partitions and the SQL Server logs are on different partitions from the database.
  • An incorrect sa password is specified during the Exchange Migrator installation when connecting to an existing SQL installation.


fix

To resolve the issue:

  1. Uninstall Exchange Migrator using the instructions provided in the following NetIQ Knowledge Base article:  NETIQKB10227: "How do I completely uninstall and reinstall Exchange Migrator?"
    • If the SQL/MSDE installation existed prior to installing Exchange Migrator, uninstall only Exchange Migrator.
    • If MSDE was installed using the Exchange Migrator installation program, then uninstall Exchange Migrator and  its database.  

  2. Perform one of the following steps that correspond to the possible causes previously listed:
    • Log on to the console machine using an account which does not contain a hyphen in the samAccountName (pre-Windows 2000 logon name) and install Exchange Migrator.
    • If you are using a machine with multiple partitions, reinstall Exchange Migrator to see if that resolves the issue.
    • Specify the correct password for the sa account.

If uninstalling and reinstalling Exchange Migrator does not resolve the issue, attempt to install MSDE separately from Exchange Migrator then uninstall Exchange Migrator again. 



note

To verify the sa password:

  1. Open a command prompt.
  2. Type: OSQL -U sa -P password (where password is the password for the sa account)
  3. Press ENTER.

You should see a prompt like 1>.  If you receive this prompt, you have entered the correct sa password.  If the password is incorrect, you will receive an error message stating that you entered an invalid logon. 



note

For more information on how to change the sa password, please refer to the following NetIQ Knowledge Base article:

NETIQKB26419:  "How do I change the SA password in MSDE?"



Additional Information

Formerly known as NETIQKB4123