How do I repair or compact the local repository? (NETIQKB3948)

  • 7703948
  • 02-Feb-2007
  • 28-Jul-2015

Environment

NetIQ AppManager 7.0.x
NetIQ AppManager 8.0.x
NetIQ AppManager 8.2

Situation

How do I repair or compact the local repository?
How do I repair and compact the local repository?
The local repository has grown too large or is corrupted.
The local repository on the Managed Client is not shrinking after communication has been restored.
NetIQ AppManager Client Communications Manager (NetIQccm) Service Uses Excessive Amount of Virtual and/or Physical Memory
Service Uses Excessive Amount of Virtual Memory
Service Uses Excessive Amount of Physical Memory

Resolution

To Repair the Local Repository (32-bit OS):
Run C:\Windows\System32\odbcad32.exe

To Repair the Local Repository (64-bit OS):

Run C:\Windows\SysWOW64\odbcad32.exe

  1. In the ODBC Data Source Administrator dialog, select the System DSN tab.
  2. In System Data Sources dialog, select the Local-Repository.
  3. Click Configure.
  4. In ODBC Microsoft Access Setup dialog, Click Repair.
  5. In Repair Database dialog, verify that the Local-Repository.mdb located in the <install path>\NetIQ\AppManager\DB directory is selected..
  6. Click OK.
  7. Click OK.

To Compact the Local Repository (32-bit OS):

Run C:\Windows\System32\odbcad32.exe

To Compact the Local Repository (64-bit OS):

Run C:\Windows\SysWOW64\odbcad32.exe

  1. In the ODBC Data Source Administrator dialog, select the System DSN tab.
  2. In System Data Sources dialog, select the Local-Repository.
  3. Click Configure.
  4. In ODBC Microsoft Access Setup dialog, click Compact.
  5. In Database To Compact From, select Local-Repository.mdb located in the <install path>\NetIQ\AppManager\DB directory.
  6. Click OK.
  7. In Database To Compact Into, select Version 4.x under Format.
  8. Click OK.
  9. Click Yes
  10. Click OK.

Cause

If communications between the AppManager Agent and AppManager Management Server fails the local repository will store data and events till communications is restored. All data and event information will then be sent to the Management Server to be inserted into the AppManager database (QDB).

It is also possible that the Agent services will show increased memory usage or fail to start when the local repository has grown too large or has become corrupted.

There is no automated way to recover the white space that is created from the local repository growth during this time and the process must be done manually.

Additional Information

Formerly known as NETIQKB3948