Environment
NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
NetIQ AppManager Connector for IBM Tivoli Enterprise Console
Situation
AppManager Connector for Tivoli Enterprise Fails to Forward Events to Tivoli Enterprise Console (TEC) or Create Log File (msadpt.log)
Events are not forwarded to Tivoli and\or a log file is not generated
Resolution
The AppManager Connector requires a valid license key.
To obtain the proper license key, contact your Sales Representative or send an email to licensekeyrequest@netiq.com and request a license key for AppManager Connector for Tivoli Enterprise.
Otherwise, locate and copy the MSVCR71.dll from another Mangement Server to ..\Program Files\Netiq\AppManager\bin of the target Mangement Server. After a restart of the Mangement Server the connector should initialize and an msadpt.log created.
Cause
The Management Server calls the adpt_tiv.dll and searches for MSVCR71.dll in its' directory..\Program Files\Netiq\AppManager\bin. AppManager 5.0.1SP2 ships with MSVCR70.dll C runtime library not MSVCR71.dll.