NT_ServiceDown reports 'No such service' when service does exist. (NETIQKB3627)

  • 7703627
  • 02-Feb-2007
  • 12-Nov-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

NT_ServiceDown reports 'No such service' when service does exist.
How do I find the correct name of the Service to use in the NT_ServiceDown knowledge script?

Resolution

To find an internal service name via the Services application:

  1. Start the Services application in Administrative Tools.
  2. Double-click the Service.
  3. Go to the General tab. The value displayed for Service Name is the internal service name.
  4. Click Cancel.

The name of the service used in the Knowledge Script Value is what is seen in the service Properties under "Service Name". This is different from the Display Name seen in the services panel, and also different from the actual filename of the service.

Cause

The wrong service name has been specified in the knowledge script values.

Additional Information

Formerly known as NETIQKB3627

The internal service name can also be found by navigating to the appropriate key in the Registry.

To find an internal service name via the Registry Editor:

  1. Open the Registry Editor (regedt32).
  2. Navigate to:

    HKEY_Local_Machine\SYSTEM\CurrentControlSet\Services
  3. The key name is the internal service name.