AMAdmin_AppManagerUninstall jobs are stuck in Running or Pending Stop state (NETIQKB3093)

  • 7703093
  • 02-Feb-2007
  • 17-Aug-2010

Environment

NetIQ AppManager 6.x

Situation

AMAdmin_AppManagerUninstall jobs are stuck in Running or Pending Stop state.
When attempting to stop the AMAdmin_AppManagerUninstall knowledge script on more than 30 AppManager Managed Clients, the job stays in a Pending Stop status.

Resolution

Jobs stuck in a pending state will need to be cleaned up manually.

To clear the Jobs in a Running or Pending Stop state:

  1. Verify the connectivity between the AppManager Management Server and the AppManager ManagedClients in question.  (See notes below)
  2. Cold start the NetIQ AppManager Management Server Service.
  3. Cold start the NetIQ AppManager Client Resource Monitor Service.

Cause

The NetIQ AppManager Management Server is responsible for running the installation and uninstallation jobs and can suffer under the load of too many concurrent jobs.  To reduce the load NetIQ recommends you limit these jobs to more more than 20 concurrent jobs.

Additional Information

Formerly known as NETIQKB3093

To test connectivity between the AppManager Management Server and the target AppManager Managed Client:

  1. Start the AppManager Operator Console.
  2. Go to Extensions | NetIQctrl.
  3. Type: trip <mc_host> netiqmc <ms_host>
    Where:

mc_host is the hostname of the Managed Client
ms_host is the hostname of the Management Server

Press Enter. This should return five lines; none of these lines should have a zero.