Environment
NetIQ AppManager 8.x
NetIQ AppManager 9.x
NetIQ AppManager Management Server
NetIQ AppManager 9.x
NetIQ AppManager Management Server
Situation
How do I remove the Management Server from the Operator Console?
Why can't I delete a server from the treeview of the Operator's Console?
When trying to delete a server from the treeview of the Operator's Console, an AppManager pop-up box appears with the message "Couldn't delete MS computer."
Why can't I delete a server from the treeview of the Operator's Console?
When trying to delete a server from the treeview of the Operator's Console, an AppManager pop-up box appears with the message "Couldn't delete MS computer
Resolution
You must change the status of the server in the repository before you can delete it. To change the status of the server in the repository, follow these steps:
In the tree view of the AppManager Operator Console, select the "old" Management Server (the server you want to remove).
Press Alt + F8. Make note of the ObjID of the Management Server.
- In the SQL Server Query Analyzer, select the Repository (QDB), and run the following SQL Statement:
UPDATE Object
SET Status = 4
FROM Object
WHERE ObjID = <ObjID_of_MS> - where ObjID_of_MS is the ID you noted is Step 2
- In the SQL Server Query Analyzer, select the Repository (QDB), and use the following SQL Statement:
SELECT * FROM MSstatus
This SQL Statement returns two entries. Verify the ObjID to ensure that you delete the correct Management Server.
Then use the following SQL Statement:
DELETE FROM MSStatus WHERE MSID = <MSID_of_MS>
Cause
The error message is generated if the server is or was a Management Server. The repository (QDB) still lists the server as a Management Server.
Additional Information
Formerly known as NETIQKB2870