Environment
AppManager 6.x
AppManager 7.0.x
Situation
Resolution
To verify the account password, from the DOS command prompt, run:
ODBCping -S (SQLserver name) -U (accountname) -P (password)
If you receive the response below, the password has been changed.
COULD NOT CONNECT TO SQL SERVER
SQLState: 28000 Native Error:4002
Info. Message: [Microsoft][ODBC SQL Server Driver][SQL Server] Login Failed
Under SQL Enterprise Manager, the password for the account would need to be changed or re-entered correctly. To verify this was the problem, rerun the ODBCping command in the DOS prompt again. You should receive a successful connection. Go back into the UI and drop a new SQL KS again. The job will now run without any problems.
Cause
- SQL sa password was changed on the machine which the agent resides on
- The account password was not entered correctly during installation of the agent.
- If the password was changed for the netiq login account, it would account for why you would get the above message.