Error: 'Error saving changes to the mailbox. The Exchange server cannot complete the requested actio (NETIQKB1814)

  • 7701814
  • 02-Feb-2007
  • 27-Jun-2007

Resolution

symptom
Error: 'Error saving changes to the mailbox. The Exchange server cannot complete the requested action.'

symptom
When an Assistant Admin clones a user account with an Exchange 5.5 mailbox in Directory and Resource Administrator's MMC interface, the following error message is displayed:

    Error saving changes to the mailbox. The Exchange server cannot complete the requested action.

fact
Directory and Resource Administrator 6.30

cause
This error occurs during the mailbox create process when Exchange is unable to locate the associated user account.

When cloning an account with an Exchange 5.5 mailbox in Directory and Resource Administrator (DRA), one of the final processes performed during the creation of the new mailbox is the setting of the mailbox's Primary NT Account. Exchange sets this property as the textual SID of the account that the mailbox belongs to. The DRA APIs send this property in the form domain\username. Exchange then performs a LookupAccountName to translate the name to resolve the SID. If this is successful, Exchange sets the associated account property.

The above error occurs if DRA creates the new user account on a different domain controller than the one Exchange queries to resolve the SID. Since replication most likely has not yet occurred at this point, the mailbox creation fails.

This situation may also occur if the Exchange server is on one domain and the user account being assigned to the mailbox is in another. For example, a user is created in the Accounts domain but Exchange Server is communicating with a domain controller in the Resource domain. After replication occurs between the two domains, the DC that Exchange Server is communicating with can evaluate the newly created user.

For more information regarding this issue, please refer to Microsoft Knowledge Base article Q252010, Creating a Mailbox and Windows NT User Account Doesn't Work.



fix
Hotfix Q12303 for Directory and Resource Administrator (DRA) 6.40 resolves this issue.

To install this hotfix:

  1. Ensure Directory and Resource Administrator 6.40 is installed on the Administration server computer.
  2. Run the DRA64000_HotfixQ12303.EXE file on the Administration server computer.

This hotfix modifies the McsExchLib.DLL files located on the DRA server. They are normally located in the Program Files\NetIQ\DRA folder.

Click on the following link to download Hotfix Q12303:



Additional Information

Formerly known as NETIQKB1814