Environment
NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
Situation
Discovery_SQL Fails with Discovery Failed Not SQL Server or SQL/MO Not Installed
Error: Discovery Failed
Error: Not SQL Server or SQL/MO Not Installed
Error: Discovery Failed
Error: Not SQL Server or SQL/MO Not Installed
Resolution
The location and filename of the SQL managed object is as follows:
- AppManager 6.x: %\NetIQ\AppManager\Bin\qsqla4.dll
- AppManager 7.0.x: %\NetIQ\AppManager\Bin\qsqla4.dll
On the target Server, verify if the managed object (q*.dll) exists.
- If the managed object exists, manually register the managed object.
- If the managed object does not exist, re-install the module.
Cause
The Discovery Failed error message typically means that the managed object has not been properly installed/registered or has become corrupted on the target Server and needs to be reinstalled.
Additional Information
Formerly known as NETIQKB1693
To manually register a managed object:
- Stop the NetIQ Services on the target Server.
- Launch a command prompt and change directories: {Install Path]\Program Files\NetIQ\AppManager\Bin
- Type the following command: regsvr32 FileName.dll Where FileName is the name of the managed object to be registered.
- For example, the name of the file for the Windows NT managed object would be as follows: Version 7.0.x: Qsqla4.dll
- Start the NetIQ Services on the target Server.
- Run the appropriate Discovery knowledge script, if applicable.