How do I manually uninstall deployed agents that have been orphaned? (NETIQKB1461)

  • 7701461
  • 02-Feb-2007
  • 06-Apr-2012

Environment

Security Manager 6.0

Security Manager 6.5

Situation

How do I manually uninstall deployed agents that have been orphaned?

How do I uninstall a managed agent that can no longer be contacted by the Central Computer?

Unable to uninstall a managed agent via Agent Administrator.

Resolution

Security Manager 6.0

Security Manager 6.5

To uninstall deployed agents that have been orphaned:

  1. Run the Manual Agent Install located on the install media for Security Manager.
  2. During the installation, update the configuration group that is orphaned. 
  3. When you are finished, there will be an Add/Remove programs entry that you can use to uninstall the agent from the server.

If the procedure above fails, you can manually uninstall agents by removing program files and registry keys of the computer where the agent resides. Please contact NetIQ Technical Support for guidance on this process.

Cause

If the central computer can no longer contact a managed agent, it can not launch the uninstall on that agent.

Additional Information

Formerly known as NETIQKB1461

Important Note:  Computers that were scanned or installed by the Agent Manager(s) at any time in the past will remain in the Control Center Console under the All Computers view since those machine names are entered in the database. In order to remove those agents, you will need to use the following steps: 

  1. Launch the Agent Administrator from the Control Center Console

  2. Launch Agent Summary

  3. Highlight the Agent(s) to remove, and use the Uninstall Button to place the Agent(s) into Pending Uninstallation

  4. Once the changes are applied, go to the Manage Pending Actions from the Agent Summary

  5. From the Manage Pending Actions, select the Agent(s) to remove, and use the Mark as Uninstalled button to hide the Agent(s) from the Agent Views.

This will keep the data about the agents, but remove them various Agent views.