Resolution
Exchange Migrator 1.x
fact
Exchange Migrator 2.x
symptom
Public Folder migration fails with errors in the Exchange Migrator EMApplog.
symptom
Error: '***(1343) Failed loading 'DAPI.DLL' [HR=0x0000007e]'
symptom
Error:'***(1371) Failed enumerating public folders [HR=0xc00459df]'
cause
Reasons for the error include the following:
Exchmem.dll
does not exist in theSystem32
directory- The path to the Microsoft Integration\Microsoft Exchange directory is not in the
Environment PATH
variable. - The mailbox you are using for the source MAPI profile does not have the correct permissions.
fix
To resolve the exchmem.dll
issue, follow these steps:
- Refer to the Note near the bottom of this article and determine if you want to verify the DAPI dependencies. If so, verify them now.
- Ensure the Exchange Migrator is closed.
- Open Windows Explorer on the Exchange Migrator console computer.
- Browse to the
Exchsrvr\bin
directory. - Copy the file
exchmem.dll
. - Paste it into the local
System32
directory
To resolve the environment PATH variable issue, add the Microsoft Integration\Microsoft Exchange directory to the environment PATH
variable.
To resolve the permissions issue, verify the account you are using for migration has the correct permissions. Refer to the following NetIQ Knowledge Base article for information about the required permissions for Exchange Migrator:
What are the software and configuration requirements for Exchange Migrator?
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB2202
note
If you would like to verify the DAPI dependencies before copying the exchmem.dll
file to the System32
directory, download and install Dependency Walker from . If you have the Windows Support Tools installed, click Start > Programs > Windows Support Tools > Dependency Walker to start Dependency Walker.
To use Dependency Walker, follow these steps:
- Click File
- Select Open
- Browse to DAPI, which is usually located in two places:
c:\Program files\Microsoft Integration\Microsoft Exchange 2000
c:\WINNT\System32
- Click Open
Any dependency displaying a yellow circle with a question mark has a problem. You may have to replace and register the corrupt file. NetIQ highly recommends researching the issue before making any changes.
note
For more information regarding the Exchange dlls required for Exchange Migrator, please refer to the following Knowledge Base article:
What Exchange DLLs does Exchange Migrator require?
https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB15740