AppManager Operator Console Failed to Detect the Repository in Logon Screen (NETIQKB716)

  • 7700716
  • 02-Feb-2007
  • 03-Nov-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

AppManager Operator Console Failed to Detect the Repository in Logon Screen.
Repository Field does not Automatically Populate the Name of the Database
Login Option is Disabled (or Grayed Out)

Resolution

To remove and recreate the NetIQ Probe and SQL Account:

  1. Change DB Owner of the Repository
    Using the SQL Server Query Analyzer, point the database to the Repository (QDB) and run the following command:
    sp_changedbowner 'sa'
    This will change the DB Owner of the Repository to the SA Account.
  2. Delete the NetIQ and Probe SQL Accounts
    Using the SQL Server Enterprise Manager, expand Security | Logins, and delete the NetIQ and Probe SQL Accounts. To do this, highlight the SQL Account to be removed, right-click, and select Delete. 
  3. Create the NetIQ and Probe SQL Accounts
    In the same window, right-click in a blank area of the right-hand pane, and select New Login. Create both the NetIQ and Probe SQL Accounts, taking all the defaults except for the Name (enter in the appropriate name: netiq or probe, all lower-case) and Authentication (select SQL Server Authentication and use netiq for the NetIQ SQL Account password and (null) for the Probe SQL Account). The probe account also needs to be granted access to the Repository database (QDB). 
  4. Change the DB Owner of the Repository
    Once both the NetIQ and Probe SQL Accounts have been created, use the SQL Server Query Analyzer, point the database to the Repository (QDB) and run the following command:
    sp_changedbowner 'netiq'
    This will change the DB Owner of the Repository to the NetIQ Account. 
  5. Verify the NetIQ and Probe SQL Accounts
    Using the SQL Server Enterprise Manager, under Security | Logins, verify that the SQL Accounts have the proper permissions:
    ? NetIQ SQL Account
    Server Roles: System Administrator
    Database Roles: QDB (Public and DB_Owner)
    ? Probe SQL Account
    Server Roles: (null)
    Database Roles: QDB (Public) 
  6. If the password has changed for the NetIQ account update the DSN, else restart the NetIQ Management Service
    On the machine hosting the NetIQ Management service
    ? Start > All Programs > Administrative Tools > Datasources (ODBC)
    ? System DSN > QDBms > Configure
    ? Modify the Sql password to the new password
    ? Proceed through wizard and save changes.
    ? Start the NetIQ Management Service

Cause

If the AppManager Repository (database) is moved from one SQL Server to another SQL Server, the SQL logins may no longer match the SQL users for the NetIQ and Probe accounts.

Additional Information

Formerly known as NETIQKB716

To view further documentation from Microsoft's web site about PRB: User Logon and/or Permission Errors After Restoring Dump (Q168001) please access the link provided below:

http://support.microsoft.com/support/kb/articles/Q168/0/01.ASP

To re-register NetIQ AppManager Management Service:

  1. On the AppManager Management Server, launch a command prompt.   
  2. Type the following command:     
        netiqms -r qdbms:qdb:netiq:netiq:SQLServerName -i
         Where:       
              
    • qdbms is the System DSN         
    • qdb is the Name of the AppManager Repository         
    • netiq is the SQL Account         
    • netiq is the Password         
    • SQLServerName is the name of the Server where the Repository resides       
      
  3. Press Enter.  This should return back to the regular command prompt when complete.