Is there a utility for troubleshooting the Directory and Resource Administrator agent service? (NETIQKB322)

  • 7700322
  • 02-Feb-2007
  • 22-Sep-2011

Environment

Directory & Resource Administrator 8.x

Situation

Is there a utility for troubleshooting the Directory and Resource Administrator agent service?

Resolution

The, EAAgentUtil.exe can be used to troubleshoot the Directory and Resource Administrator agent service (NetIQ DRA Agent). The executable is installed in the DRA directory by selecting the Utilities component in the setup program.

This utility should be run from a Command Prompt. The following options are available for use.

Usage:
EaAgentUtil {/install | /uninstall} computer name {domain name\}user name

    The user account specified in the above syntax must have administrative privileges to install a service on the specified machine. Once installed, the agent will run under the credentials of the local system.

EaAgentUtil {/register | /unregister} computer name {domain name|\\member server name}

EaAgentUtil /register <computer name> <domain name>

EaAgentUtil /status <computer name>



Cause

Directory and Resource Administrator uses an agent on the Domain Controllers in your Managed Domains. DRA uses this agent to communicate with the DCs directly. If the agent has problems, there is a need to diagnose some of those issues.

Additional Information

Formerly known as NETIQKB322

DRA Versions 8.5, 8.5 SP1, and 8.6 only use the DRA Agent for last logon time stamp collection.

DRA Version 8.6 SP1 no longer uses the DRA Agent nor Deploys the agent.