How do I use the Directory and Resource Administrator diagnostic utility (DRADiagnosticUtil.exe)? (NETIQKB305)

  • 7700305
  • 02-Feb-2007
  • 05-Jan-2012

Environment

Directory and Resource Administrator 8.x

Situation

How do I use the Directory and Resource Administrator diagnostic utility (DRADiagnosticUtil.exe)?

How do I gather Diagnostic Logs for Technical Support?

Resolution

The Diagnostic Utility (DRADiagnosticUtil.exe) is used to gather information for troubleshooting Directory and Resource Administrator server issues.

The Diagnostic Utility can be customized to gather the following information from your Administration server:

Reporting Trace Files

    The utility collects this information from DRA Reporting logs. If you have not installed the Reporting interface, the utility is unable to collect any Reporting information.

Server Trace Files

    The utility collects this information from the Administration server logs.

Registry Settings

    The utility collects this information from the entire Administration registry entry under the HKEY_Local_Machine\Software entry.

Licensing Information

    The utility collects information about the current effective license.

System Event Log

    The utility collects this information from the Windows 2000 System Event Log.

Service Configurations

    The utility collects a list of the services running on the Administration server including the service type, status, and logon parameters.

Application Event Log

    The utility collects this information from the Windows 2000 Application Event Log.

GUI Logs

    The utility collects this information from the Administration MMC interface log.

Install Information

    The utility collects this information from a subset of the entire registry.

Server State Information

    The utility collects internal Administration server information. If the Administration server is not currently running, the utility is unable to collect any server state information. In addition, the data collection process fails. If the collection process fails, clear the Server State Information check box and re-run the utility.

File Times and Sizes

    The utility collects the time stamp and size for each file in the Program Files\NetIQ OnePoint\OnePoint folder on your Administration server.

To use the Diagnostic Utility:

  1. Log on to the Administration server using the service account.
  2. Open the Diagnostic Utility (DRADiagnosticUtil.exe) in the following folder: \Program Files\NetIQ\DRA.
  3. In the section 1. Set server trace level, use the drop down menu and set the level to High, then click Apply.  Setting the level to high will log the server activity in a more detailed fashion.
  4. Reproduce the problem you are having in DRA.  While you repeat the problem, you have the option to leave the utility running or you can close it out.
  5. After the problem has been reproduced, return to the DRADiagnosticUtil window, or restart the utility if it has been shut down.
  6. Check all options unless a Technical Support engineer requests more specific settings. For more information about which settings to select, consult NetIQ Technical Support.
  7. Click Collect Data to begin gathering diagnostic data.
  8. Once the zip file has been created, set the server trace level back to None and click Apply.
  9. Close the DRADiagnosticUtil.exe utility.

After the logs have been gathered email the logs to NetIQ Technical Support for review.



Cause

When working with NetIQ Technical Support, there is often a need to gather multiple DRA logs for furhter review by TS. The DradiagnosticUtility will enable the customer to change the log level and gather the logs into a single zip file.

Additional Information

Formerly known as NETIQKB305