NetIQ Management Server Service will not start (NETIQKB57)

  • 7700057
  • 02-Feb-2007
  • 30-Nov-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
NetIQ AppManager Management Service

Situation

NetIQ AppManager Management Server Service will not start.
In the Application Event Log you have an error indicating; MSIOCAdd nqioc_bind failed.

Resolution

Important: This article contains information about editing the Registry. Before editing the Registry, it is recommend that the Registry be backed up in case a problem occurs.

Stop the NetIQ AppManager Management Service (NetIQms) if it is not already stopped. Using Regedt32, open the registry and change the following key:

HKLM\Software\NetIQ\AppManager\4.0\netiqms\Config

  • PIOC Data Map File Size MB
  • PIOC Event Map File Size MB
  • PIOC JobStat Map File Size MB

By default all of these will be set to 5, change them all to 10.

Next Verify the following in the same registry key:

  • PersistentIOC =1
    if this is set to 0 change it to 1
  • PIOC Map File Path
    By default this is located at c:\program files\netiq\appmanager\dat\pioc\.  This is the location that hosts the PIOC files. It should be populated for PIOC's to properly work.  You can change the above path to match your actual install path.  DO NOT use UNC paths (i.e. \\Server\Share\path or \\Server\C$\path).  It must use the standard path (i.e. C:\<InstallPath>\Netiq\... or D:\<InstallPath>\Netiq\...).

Once the changes have been made you will need to restart the NetIQms service.

Cause

This may occur if the NetIQMS is receiving data faster than it can be stored in the Repository. In these instances the data is cached locally to a file on the Management Server machine. If that file reaches it limit the NetIQMS may shut down. Raising the limit of this file should alleviate this issue.

Additional Information

Formerly known as NETIQKB57