Environment
iPrint Appliance 2.x, 3.x, 4.x
iPrint For OES
iPrint Advanced
iPrint on OES2015
iPrint on OES2018
iManager
Situation
When attempting to modify the Access Control option for the Print Manager object, a 'NDS Error -601 The object name entered could not be found in the context specified' is returned.
Resolution
Locate the invalid object in eDirectory and rename it. See Additional Information below for steps on how to locate the invalid object.
Cause
An object with a [Tab] preceding the name existed in the Access Control list.
Additional Information
Open the PADBTXT.XML file on your iPrint appliance or server. The file is located in:
/var/opt/novell/iprint/<youriprintmanagerobjectname.yourOU.yourO.psm>
In the PADBTXT.XML file toward the top of the file you will see a reference to your print manager object. Below the print manager object details you will see <acl> followed by entries that look similar to this (The data will be specific to your environment):
<item><role>manager</role><trustee>CN=iprint18,O=home</trustee></item>
<item><role>manager</role><trustee>CN=admin,O=home</trustee></item>
<item><role>manager</role><trustee>CN=OESCommonProxy_oes2018,O=home</trustee></item>
<item><role>manager</role><trustee>CN= Group1,O=home</trustee></item>
<item><role>manager</role><trustee>CN=Group2,O=home</trustee></item>
<item><role>manager</role><trustee>CN=admin,O=home</trustee></item>
<item><role>manager</role><trustee>CN=OESCommonProxy_oes2018,O=home</trustee></item>
<item><role>manager</role><trustee>CN= Group1,O=home</trustee></item>
<item><role>manager</role><trustee>CN=Group2,O=home</trustee></item>
In this specific case there was an entry that had what appeared to be spaces in front of the object name as in the example above for the object Group1. After locating the 'problem' object in iManager, the object was renamed without the blank spaces and this resolved the -601 error.