'Authentication service is not reachable' accessing iPrint Directory Servers

  • 7025117
  • 21-May-2021
  • 26-May-2021

Environment

iPrint Appliance 4.x

Situation

After upgrading the iPrint Appliance 3.x to the 4.x version, when accessing the Directory Servers option the following message is returned:
Authentication service is not reachable
The Directory Servers option is accessed by clicking on Manage iPrint Appliance in the 9443 interface.

Checking System Services in the 9443 interface shows the iPrint Authentication Service is Stopped.

Resolution

Using a utility like putty or any SSH client, check the /etc/opt/novell/iprintauth/conf directory for the following files:
credentials.dump
directory.json
If they exist, delete them and then start the iPrint Authentication Service.  Starting the service can be done in the 9443 interface by highlighting the service and clicking on the Action drop-down and selecting Start.  If you prefer to use your SSH client, you can start the service with this command:
systemctl start iprint-auth
You can check the status of the service with this command:
systemctl status iprint-auth
Once you confirm the iPrint Authentication Service is in a Running state you should be able to access the Directory Servers configuration.

Cause

During the upgrade process the credentials.dump and the directory.json files were not removed.

Additional Information

By default the SSH service is not running on the iPrint Appliance.  In order to connect to the appliance with your preferred SSH client, you will first need to start the SSH service which is done in the 9443 interface by clicking 'System Services', click on SSH and click Action | Start.