Managed apps are not being installed consistently on mobile devices

  • 7025116
  • 21-May-2021
  • 01-Jun-2021

Environment

ZENworks Configuration Management 2020 Bundles
ZENworks Configuration Management 2017 Update 4 Bundles
ZENworks Configuration Management 2017 Update 3 Bundles
ZENworks Configuration Management 2017 Update 2 Bundles
ZENworks Configuration Management 2017 Update 1 Bundles

Situation

When creating an assigning mobile managed app bundles, there is inconsistency with the delivery of the managed applications to the devices.  Some devices may receive the apps without any issue.  Some devices may receive some apps, but not all that are properly assigned.

Resolution

If the administrator wants to enforce that certain mobile applications must be installed on devices, it is recommended to assign the bundles with the setting "Every Refresh". This also resolves inconsistent behaviors.  If for any reason the installation of the bundle fails, it will continue to try again during each refresh. 

Cause

The assignment of the app bundle can be handled in two different ways.

  • Next Refresh indicates that the app is being sent to the device on the subsequent refresh of the device.  The next time the device refreshes with the primary server, an installation attempt is made.  It is a one time notification.  Therefore, if something occurs where the app is not installed, or a user uninstalls the app after it has been installed, it will not be attempted a subsequent time.
  • Every Refresh indicates that the notification will be sent to the device every time a refresh action is performed on the device.  This means that if something occurs where the app is not installed on one refresh, or a user uninstalls the app after it has been previously installed, it will be installed on the device again with the next refresh.