Remote Manager (NRM) fails to start with error: Start operation timed out

  • 7025062
  • 26-Mar-2021
  • 26-Mar-2021

Environment

Open Enterprise Server 2018 (OES 2018) Linux
Open Enterprise Server 2018 SP1 (OES 2018 SP1) Linux
Open Enterprise Server 2018 SP2 (OES 2018 SP2) Linux

Situation

Remote Manager (NRM) fails to start with error:  Start operation timed out.

Running the command: systemctl status novell-httpstkd.service  returns that the service isn't running.
Running the command: systemctl start novell-httpstkd.service takes several minutes and then returns this error:
Job for novell-httpstkd.service failed because a timeout was exceeded. See "systemctl status novell-httpstkd.service" and "journalctl -xe" for details.
This is part ot the journalctl -xe command
<Date - Time> myServer systemd[1]: novell-httpstkd.service: Start operation timed out. Terminating.
<Date - Time> myServer systemd[1]: Failed to start Novell httpstkd Daemon.
-- Subject: Unit novell-httpstkd.service has failed



Resolution

The work around to this is to kill and then restart novell-httpstkd.service (note:  a systemctl stop or restart wasn't sufficient).  Issue these two commands:
 systemctl kill novell-httpstkd.service
 systemctl start novell-httpstkd.service
After running those two commands, the service should run fine until the next reboot.

Cause

Thank you to the Novell / Micro Focus community for providing the work-around to this in this forum post:
Specifically:
it seems this only happens during boot on multicore machines (real and virtual), single-core seems unaffected.
To get it to start manually in this situation, you need to do:
 systemctl kill novell-httpstkd.service
 systemctl start novell-httpstkd.service
After that it should run normally until the next reboot.

This has been submitted as a defect.